Raspberry Pi B+ Reboot Loop

Bei dem Raspberry Pi, der mir am Fernseher als Mediacenter dient, war der Netzwerk-Anschluss kaputt gegangen, also musste dafür Ersatz her. Mittlerweile gibt es den Pi B+, der ja bekanntlich ein paar Vorteile gegenüber dem alten Modell hat, in erster Linie mehr RAM und mehr USB-Ports. Also habe ich einen B+ bestellt.

Nachdem der Pi angekommen war spielte ich wie gewohnt OpenELEC auf die SD-Karte, schloss den Pi wie gehabt an den Fernseher an und erwartete den ersten Start. Leider ging hier direkt das Problem los, kaum war die Oberfläche von XBMC zu sehen startete er direkt wieder neu. Raspbmc, das ich als nächstes probierte, bootete ebenfalls nicht, während des Boot-Vorgangs konnte man sehen dass ständig der USB-Hub neu gefunden wurde, irgendwann endete der Boot dann mit einem Segmentation Fault. Zuletzt probierte ich Raspbian, das startete allerdings gar nicht erst.

P1260315Während der Fehlersuche stieß ich auf diesen Beitrag, den ich eigentlich nur der Vollständigkeit halber dann auch noch überprüfte, und siehe da: das Netzteil, das ich bisher mit dem alten Pi benutzt hatte liefert nur 180mA … das kam mir dann doch etwas wenig vor. Anderes Netzteil probiert, und schon läuft der Pi problemlos.

Schwarz-Weißes Bild beim Anschluss vom Raspberry Pi an einen analogen Fernseher

Der Raspberry Pi hat bekanntlich neben dem HDMI-Ausgang noch einen Composite Video-Ausgang mit dem man ihn an einen analogen Fernseher anschließen kann. Dafür benötigt man lediglich ein Cinch-Kabel, die für Video gedachten Kabel haben in der Regel gelbe Stecker.

Schließt man den Pi so an den Fernseher an dann kann es passieren dass auf dem Fernseher nur ein leicht verzerrtes Schwarz-Weiß Bild ankommt. Schwarz-Weißes Bild beim Anschluss vom Raspberry Pi an einen analogen Fernseher weiterlesen