Linksys Router als einziges Gerät nicht anpingbar

Ich habe meinen in die Jahre gekommenen Fileserver durch einen neuen Server mit ESXi 5.1 ersetzt und den Fileserver in eine virtuelle Maschine darauf migriert. Um Konsistenz zu wahren blieben Hostname, IP etc gleich. Nach der Installation hatte ich folgendes Problem:

Aus der VM heraus ließ sich alles im lokalen Netzwerk anpingen, andere Rechner, andere VMs, der Host, nur der Gateway (und damit auch Adressen im Internet) antwortete nicht auf Pings. Das Problem bestand nur bei der einen VM, in einer anderen VM auf dem gleichen Host ging es problemlos.

Nach viel Sucherei und Herumprobieren stolperte ich dann mehr zufällig über die Lösung: Ich hatte vor ein paar Wochen die DNS- und DHCP-Funktionalität des Routers deaktiviert und auf einen Raspberry Pi ausgelagert. Den DHCP-Server des Routers hatte ich deaktiviert, die Konfiguration war jedoch noch vorhanden, inklusive der reservierten IP-Adressen. Ein paar Geräte (darunter auch der Fileserver) haben anhand ihrer MAC-Adresse immer die gleiche feste IP-Adresse bekommen. Kaum hatte ich den Fileserver aus der (immer noch deaktivierten) Reserved DHCP-Konfiguration entfernt wurden auch gleich meine Pings an den Router und an Adressen im Internet beantwortet.

Ich vermute dass der Linksys-Router die Reserved DHCP-Tabelle als Quelle für ARP-Auflösungen nutzt und damit die Antworten auf die Pings an die alte MAC-Adresse geschickt hat.

Veröffentlicht von

Gerald

Diplom-Informatiker (DH) in Darmstadt. Ich blogge über Entwicklung, Internet, mobile Geräte und Virtualisierung. Meine Beiträge gibt es auch bei Google+ und Facebook.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.